Home Forums Lansupport Enable LanSupport Application to run separately from the Database server

This topic contains 0 replies, has 1 voice, and was last updated by  admin 1 year, 1 month ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #3208

    admin
    Keymaster

    When LanSupport is installed on server A and SQL database is running on server B, MSDTC is required in order for the transactions to be successful. Below are the steps for enabling MSDTC,

    1. On both the servers make sure DTC is running, to do this go to services, make sure Distributed Transaction Coordinator is running and startup type is Automatic.
    2. To allow remote transactions connection, on both the servers:
      1. Go to Administrative Tools -> Component Services
      2. Expand Component Services -> Computers -> My Computer -> Distributed Transaction Coordinator
      3. Right-click on Local DTC -> Properties -> Security tab, enable network DTC access as per the diagram below:-

     

    1. On the server running SQL database, open SQL Management studio and connect to your instance. Right click on the Instance and go to properties. Under properties click on connections and enable ‘Allow remote connections to this server’ and ‘Require distributed transactions for server-to-server communication’ as per the diagram below

     

    1. Next step on both the servers, you can either disable your firewall or have your Firewall allow port 135 and the dcom port range both Inbound Rules and Outbound Rules. By default, the dcom port range is 1024-65535. That’s a big range to open up. You can limit this range in the registry or using dcomcnfg as shown below;

    RESTRICTING THE DCOM PORT RANGE

    1. Go to Start -> Run. Type in DCOMCNFG.
    2. Go to the properties of the My Computer node under the Computers folder underneath Component Services.
    3. Under the My Computer Properties look under the Default Protocols tab.
    4. Over there make sure that Connection-oriented TCP/IP is selected and then click on Properties.

     

     

    5. You will see a window like this

     

    If you don’t see a range above and the window looks exactly like the one above, that would mean that the DCOM port range is not configured on the machine.
    You can click Add in the above window and type the range (let’s say as 5000-5100) and say Ok. Make sure it looks like this. (Both the radio buttons should be selected for Internet Range)

    You have to configure this range on both the machines and after that you have to reboot both the servers for this Range to take effect. After doing that you have to open up the same range on your firewall bi-directionally.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.